Jump to content

Firefox pēkšņi sācis ignorēt Heading tagus


eziic
 Share

Recommended Posts

Netieku galā ar vienu Firefox gļuku - vai nu pēc kāda Windows updeita vai paša FF updeita sākuši gļukot Heading tagi konkrētām lapām. Zemāk bildē piemērs - pa kreisi atvērta lapa FF, pa labi tā pati lapa Chrome. Izmēģināju visādi - uztaisīju Firefox refrešu, downgreidoju uz vecāku versiju, nonesu pavisam iztīrot arī AppData mapi, ieinstalēju par jaunu - bez izmaiņām. Uz otra datora iekš FF lapa rādās normāli, tātad gļuks konkrēti vienā datorā.

 

NJaFOR7.png

Link to comment
Share on other sites

raivix95

Nav kaut kas ar fontiem Windowsā sagājis ķīselī? Vai arī kaut kāds accessibility nevarētu būt?

Link to comment
Share on other sites

AndrisBB

Būtu vismaz piemēru ielicis, lai atvērt Hromā un Firefoxā un salīdzināt.

Paskaties inspektorā, kādu stilu tiem fontiem izvēlas viens, un kādu otrs. Varbūt nemaz nav vienādi.

Link to comment
Share on other sites

Posted (edited)
Pirms 7 minūtēm , Jurkins teica:

A kur tas gļuks? Fonti ne tādi?

Augšā 'CATEGORIES' ir H4 tags. FF fonts pareizs, bet ignorē, ka jābūt boldā utt, Chrome savukārt viss ok. Lejā uz banera 'SALE' tas pats.

 

Pirms 6 minūtēm , AndrisBB teica:

Būtu vismaz piemēru ielicis, lai atvērt Hromā un Firefoxā un salīdzināt.

Kā jau minēju - parāvu vaļā uz cita datora, tur gan FF, gan Chrome viss 1:1 līdz ar to domāju, ka neizdosies uz sava PC to gļuku atkārtot. Anyway links testam TE.

Edited by eziic
Link to comment
Share on other sites

AndrisBB

Man abi izvēlas vienu un to pašu fontu un vienādā "resnumā".

 

Screenshot from 2022-06-17 20-40-49.png

Screenshot from 2022-06-17 20-41-01.png

 

 

Ielādē no Google fontiem.

 

/* latin-ext */
@font-face {
  font-family: 'Karla';
  font-style: normal;
  font-weight: 700;
  src: url(https://fonts.gstatic.com/s/karla/v22/qkB9XvYC6trAT55ZBi1ueQVIjQTD-JrIH2G7nytkHRyQ8p4wUjm6bnEr.woff2) format('woff2');
  unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
}

 

Edited by AndrisBB
Link to comment
Share on other sites

Jurkins

Es kādu mēnesi lapsai spiedu "dismiss" uz aicinājumu atjaunot. Tavs links rādās normāli. Tagad speciāli nospiedu apdeitot. Viss tāpat.

Link to comment
Share on other sites

Pirms 15 minūtēm , AndrisBB teica:

Man abi izvēlas vienu un to pašu fontu un vienādā "resnumā".

 

Screenshot from 2022-06-17 20-40-49.png

Screenshot from 2022-06-17 20-41-01.png

Nočekoju inspectā gan FF, gan Chrome tieši uzrakstu 'CATEGORIES', abiem vienādi parametri, bet FF joprojām rāda savādāk -

Chrome

oCeXXBh.png

FF

wUu1RL0.png

 

Pirms 4 minūtēm , inteens teica:

Kāda motivācija vispār  lietot lapsu, es sensen atpakaļ 1 reiz pamēģināju.

Pašos pirmsākumos lietoju Operu, jo dators bija 

Nav motivācijas, tik cik padsmit gadu vecs ieradums. Sen jau meklēju alternatīvu, kas nav Chrome/Opera, bet te ne par to stāsts.

 

Pirms 12 minūtēm , Jurkins teica:

Es kādu mēnesi lapsai spiedu "dismiss" uz aicinājumu atjaunot. Tavs links rādās normāli. Tagad speciāli nospiedu apdeitot. Viss tāpat.

Jā, izskatās, ka gļuks tieši datorā nevis pārlūkā - mēģināju instalēt vecākas FF versijas, bet bez rezultāta.

  • Patīk 1
Link to comment
Share on other sites

AndrisBB

Hroms pats renderē fontus, Firefox izmanto OS. Varbūt tev GPU nav jēdzīgi sakonfigurēts. Izslēdz Firefoxā HW renderingu.

Vai arī Windowsā esot Display Settings > Display > Advanced display settings > Related settings > ClearType text

  • Patīk 1
Link to comment
Share on other sites

Posted (edited)
Pirms 31 minūtēm , AndrisBB teica:

Ielādē no Google fontiem.

 

/* latin-ext */
@font-face {
  font-family: 'Karla';
  font-style: normal;
  font-weight: 700;
  src: url(https://fonts.gstatic.com/s/karla/v22/qkB9XvYC6trAT55ZBi1ueQVIjQTD-JrIH2G7nytkHRyQ8p4wUjm6bnEr.woff2) format('woff2');
  unicode-range: U+0100-024F, U+0259, U+1E00-1EFF, U+2020, U+20A0-20AB, U+20AD-20CF, U+2113, U+2C60-2C7F, U+A720-A7FF;
}

 

Pamēģināju šo - nepalīdz. Tāpat FF pie settings/fonts ir ķeksis pie 'Allow pages to choose their own fonts, instead of your selections above'.

 

EDIT* HW atslēdzu, ClearType arī noņēmu - bez rezultāta. Pirms pāris dienām viss vēl bija ok, vienīgais, ko atradu, kas bez FF updeita pa šo laiku mainījies - kompis vakar dabūjis security updeitu KB5014702. Pamēģināšu noņemt to.

 

 

Edited by eziic
Link to comment
Share on other sites

Par turpmāku opfftopiku būs soda sankcijas.

Link to comment
Share on other sites

Jāatceras - ja pārlūks neatrod kādu fontu, tad notiek fallback uz kādu citu. Pirmais ko pārbaudīt - vai tādi fonti ir sistēmā, pārlūkā, ja tie nav automātiski pieejamie, tad vai tie veiksmīgi ielādējas no lapas, vai kā citādi pārlūks tos ielādē, lai varētu norenderēt.

  • Patīk 1
Link to comment
Share on other sites

AndrisBB

Tā lapa jau ielādē fontus no Google. Nav jau tā ka neatrastu vai kas cits, tik tas ka renderē nepareizi.

  • Patīk 1
Link to comment
Share on other sites

Interesants gadījums, īpaši ja citā kompī tas pats OK, un arī agrāk bija OK uz šī kompja.

 

Ja fonti ielādējas, tikai nekorekti renderējas, uz viena FF ir OK, uz cita ne... Var provēt no cita FF profila tajā pašā kompī, no jauna FF profila  - pēdējais ļaus izslēgt lietotāja izmainītos FF uzstādījumus.
Tad vēl var izvirst ar Portable FF versijām - pamēģināt to uz viena kompja kur nav OK, un uz cita, kur ir OK. Portable FF viss ir iekļauts, arī visi uzstādījumi.

 

  • Patīk 1
Link to comment
Share on other sites

Noņēmu pēdējo Windows updeitu - bez izmaiņām.

 

Par FF Portable neiedomājos, laba ideja. Nopumpēju no portableapps, palaidu - tas pats efekts, gļuko. FF profils arī nebūs variants, kaut kas pašā datorā salūzis. Protams, ka ātrais risinājums ir samainīt pārlūku uz Chrome un aizmirst šo jautājumu, bet te jau ieslēdzās princips. :)

Link to comment
Share on other sites

raiviic
pirms 11 stundām , eziic teica:

ir samainīt pārlūku uz Chrome

Pamēģini ūdenslapsu (tika lietota uz W7, tagad uz W10/11 atkal FF) - vai tīru Chromium (to lietoju uz Linux), pret Chrome man alerģija:biggrin:.

Edited by raiviic
Link to comment
Share on other sites


Nav ieslēgts high contrast setings pašā OS ?

 

Check:  `Note that you appear to be running uBlock Origin, so make sure not to "block remote fonts" in UBO.`

 

Vēl var gadīties corrupted fonti, varbūt izdzēs, lai ielādē no jauna?

 

Vēl var pamainīt pašus video setingus, kaut kādi renderingi un akselerātorri mēdz nograut tekstus.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...